Voorwaardelijke opmaak

Truc: Maak tekstkleur gelijk aan achtergrondkleur.

Wanneer je in excel een tabel maakt met bijvoorbeeld Voornamen en daarachter Kleurenvoorkeuren, komen sommige Namen meerdere keren voor.
Om de excelsheet dan wat mooier te maken, kun je de cellen die onder elkaar dezelfde Voornaam bevatten samenvoegen en de Voornaam dan één keer typen.

Voornaam Voorkeurkleur
Tjitse Rood
Sanja Zwart
Blauw
Geel

Ik raad je dat AF ....
Want: Wil je er een draaitabel van maken ...., dan gaat die er niet zo uit zien zoals je zou willen.

Wat dan?

Typ echt overal de Voornaam.
Voeg een extra kolom in, waarin je met een formule een 0 of een 1 plaatst: een 0 als de cel boven de Voornaam gelijk is, een 1 als de cel ongelijk is.
De formule in B2 is: =ALS(ISLEEG(A3);0;ALS(A2=A1;0;1))


Voornaam Uniek Voorkeurkleur
Tjitse 1 Rood
Sanja 1 Zwart
Sanja 0 Blauw
Sanja 0 Geel

Voor het 'mooie' kun je nu voorwaardelijke opmaak toepassen.
In dit voorbeeld gebruik ik geen wit maar lichtblauw (omdat je anders niet kunt zien wat er staat).



Hoe maak je de formule voor voorwaardelijke opmaak?

Selecteer op het blad eerst alle cellen waarvoor de voorwaardelijke opmaak moet gelden ($A$2:$A$5 in dit voorbeeld).
Ga dan naar voorwaardelijke opmaak en maak een nieuwe regel.
Bij formule BEGIN je met =   ! Let op: Voor de 2 in $B2 staat geen $ !!
[Het lijkt wat vreemd alleen $B2 aan te geven, maar excel past de formule voor de onderliggende cellen zelf aan]

Hieronder het resultaat in lichtblauw.

Voornaam Uniek Voorkeurkleur
Tjitse 1 Rood
Sanja 1 Zwart
Sanja 0 Blauw
Sanja 0 Geel

Hieronder het resultaat met wit als achtergrondkleur. De kolom Uniek is verborgen.

Voornaam Voorkeurkleur
Tjitse Rood
Sanja Zwart
Sanja Blauw
Sanja Geel